UK Live disruption

Incident Report for Enable

Resolved

This incident has been resolved. Full performance has been restored after a momentary disruption of approximately 10 minutes.
Posted May 01, 2026 - 13:15 UTC

Investigating

We're currently aware of an issue impacting load times in our UK Trading Programs environment. We will provide updates as soon as we can.
Posted May 01, 2026 - 12:52 UTC
This incident affected: Trading Programs (Trading Programs UK).